admin / 08.04.2020

Значение не является значением объектного типа 1С

При внесении информации автоматически элементы изменяют категорию вводных, создаются определенные удобства, что в ряде случаев может стать для программы серьезной преградой.

О чем говорит ошибка значения 1С в ячейках?

Оповещение «Значение 1С не относится к объектному типу» указывает на присутствие в табличных ячейках, обрабатываемых программным модулем, неправильного типа данных, предусмотренных изначально. Если шаблоны заполняются от руки, любой символ, кроме разделительной точки, способен сделать строку вместо цифрового значения 1С, а лишняя точка преобразовать сведения в позицию «дата».

В дальнейшем использование такого документа становится некорректным, так как в процессе выполнения проводок таблица пополняется неверными характеристиками. При формировании выборки и установки фильтра «по дате» форма выдает не дату, а строку с указанием на присутствующее несоответствие.

Настроить отображение значения в 1С поможет отмена документации, пока требуемый файл не будет сформирован верно. При этом бланк с ошибкой необходимо удалить и ввести вручную. Если причиной появления неточности со значением 1С является деятельность программиста, исправлять недочет придется в конфигураторе.

Специалисты компании «АйТи-Консалтинг» обладают большим опытом работы в сфере настроек и обслуживания приложений «1С: Предприятие 8.3». Вы сможете получить ответы на самые распространенные вопросы по значениям в 1С.

Быстрый переход Программы для бюджетного учета Вверх

  • Навигация
  • Кабинет
  • Личные сообщения
  • Подписки
  • Кто на сайте
  • Поиск по форуму
  • Главная страница форума
  • Форум
  • Бухгалтерия
    1. Общая бухгалтерия
      1. Бухучет и Налогообложение
      2. Оплата труда и кадровый учет
      3. Документация и отчетность
      4. Учет ценных бумаг и валютных операций
      5. Внешнеэкономическая деятельность
      6. Внешнеэкономическая деятельность. Таможенный союз
      7. Алкоголь: лицензирование и декларирование
      8. Онлайн-ККТ, БСО, эквайринг и кассовые операции
    2. Отрасли и спецрежимы
      1. Индивидуальные предприниматели. Спецрежимы (ЕНВД, УСН, ПСН, ЕСХН)
      2. Учет в НКО и жилищном хозяйстве
      3. Бухгалтерский учет в строительстве
      4. Бухгалтерский учет в туризме
    3. Бюджетные, автономные и казенные учреждения
      1. Бюджетный учет
      2. Программы для бюджетного учета
    4. Банки
    5. МСФО, GAAP, управленческий учет
  • Юридический отдел
    1. Правовая помощь
    2. Регистрация
    3. Опыт проверок
  • Управление предприятием
    1. Администрирование и управление на предприятии
    2. Аутсорсинг
  • Автоматизация предприятия
    1. Программы для ведения бухгалтерского и налогового учета
      1. Инфо-Бухгалтер
      2. Другие программы
    2. 1C
    3. Электронный документооборот и электронная отчетность
    4. Прочие средства автоматизации труда бухгалтеров
  • Гильдия клерков
    1. Взаимоотношения на работе
    2. Бухгалтерский бизнес
    3. Обучение
    4. Биржа труда
      1. Ищу работу
      2. Предлагаю работу
  • Клуб Клерк.Ру
    1. Пятница
    2. Частные инвестиции
    3. Политика
    4. Спорт. Туризм
    5. Встречи и поздравления
    6. Авторские форумы
      1. Интервью
      2. Простое, как мычание
      3. Авторский форум Goblin_Gaga
        1. Бухгалтера можно…
        2. опусник Гаги
  • Интернет-конференции
    1. Кому я должен — всем прощайте: все о банкротстве физлиц
    2. Архив Интернет-конференций
      1. Интернет-конференции
        1. Обмен электронными документами и сюрпризы от ФНС
        2. Нарушение прав граждан при трудоустройстве и увольнении
        3. Новый порядок сдачи отчетности по НДС в электронном формате
        4. Подготовка годовой финансовой/бухгалтерской отчетности за 2014 год
        5. Все, что вы хотели спросить у оператора обмена электронными документами
        6. Как финансовый кризис превратить в окно возможностей?
        7. НДС: изменения в нормативном регулировании и их реализация в программе «1С:Бухгалтерия 8»
        8. Обеспечение достоверности результатов инвентаризационных мероприятий
        9. Защита персональных данных. Применение ЗПК «1С:Предприятие 8.2z»
        10. Формирование учетной политики компании: возможности сближения с МСФО
        11. Электронный документооборот на службе бухгалтера
        12. Учет времени при различных системах оплаты труда в программе «1С:Зарплата и управление персоналом 8»
        13. Полугодовой отчет по налогу на прибыль: раскроем все секреты
        14. Межличностные отношения на рабочем месте
        15. Облачная бухгалтерия 1С. Стоит ли уходить в облако?
        16. Банковские депозиты: как не потерять и выиграть
        17. Больничные листы и другие пособия за счет ФСС. Порядок расчета и начисления
        18. Клерк.Ру: задайте любой вопрос руководству сайта
        19. Правила расчёта НДС при осуществлении экспортно-импортных операций
        20. Как сдать отчетность в Пенсионный фонд за 3 квартал 2012 года
        21. Отчетность в ФСС за 9 месяцев 2012 года
        22. Подготовка отчетности в ПФР за 2 квартал. Сложные вопросы
        23. Запуск электронных счетов-фактур в России
        24. Как снизить затраты на ИТ-оборудование, ПО и ИТ-персонал с использованием облачных мощностей
        25. Отчетность в ПФР за 1 квартал 2012. Основные изменения
        26. Налог на прибыль: нюансы заполнения декларации за 2011 год
        27. Годовая отчетность в ПФР. Актуальные вопросы
        28. Новое в бухгалтерской отчетности за 2011 год
        29. Отчетность в ФСС в вопросах и ответах
        30. Полугодовая отчетность в ПФР в вопросах и ответах
        31. Расчет пособий по временной нетрудоспособности в 2011 году
        32. Электронные счета-фактуры и электронные первичные документы
        33. Формирование бухгалтерской отчетности за 2010 год
        34. Расчет больничных в 2011 году. Декретные и пособия в переходный период
        35. Новое в законодательстве о налогах и страховых взносах в 2011 году
        36. Изменения в финансовой отчетности в 2011 году
        37. DDoS атаки в России как способ нечестной конкурентной борьбы.
        38. Банковские продукты для физлиц: кредитование, депозиты, спецпредложения
        39. Документ в электронной форме — эффективное решение актуальных проблем
        40. Как найти работу с помощью Клерк.Ру
        41. Предоставление сведений перс. учета за первое полугодие 2010 года
        42. Налоговая ответственность: кто и за что отвечает?
        43. Проверки, взыскание, возврат/зачет налогов и др.вопросы ч.1 НК РФ
        44. Расчет больн. листов и страховых взносов в свете квартальной отчетности
        45. Замена ЕСН страховыми взносами и другие нововведения 2010 года
        46. Ликвидация коммерческих и некоммерческих организаций
        47. Бухгалтерский и налоговый учет товарно-материальных ценностей
        48. Обязательная перерегистрация фирм в соответствии с Законом №312-ФЗ
        49. PR и маркетинг в сфере профессиональных услуг своими силами
        50. Клерк.Ру: смена дизайна
        51. Построение личного финансового плана: мечты и реальность
        52. Подготовка бух. отчетности. Изменения в рос. стандартах учета в 2009 году
        53. Откаты в сфере продаж: за и против
        54. Потеря работы в период кризиса. Что делать?
        55. Все, что вы хотели знать о Клерк.Ру, но стеснялись спросить
        56. Кредит в кризис: условия и возможности
        57. Сохранение капитала во время кризиса: стратегии для частных инвесторов
        58. НДС: вычеты по авансам. Вопросы с ответами и без
        59. Пресс-конференция Деда Мороза
        60. Изменения в Налоговый кодекс, вступающие в силу с 2009 года
        61. Налог на прибыль с учетом последних изменений и разъяснений Минфина
        62. Российский кризис: угрозы и возможности
        63. Сетевой бизнес: качественные товары или развод на деньги?
        64. КАСКО: страховка без секретов
        65. Выплаты физическим лицам
        66. Рейдерство. Как защитить собственный бизнес?
        67. Актуальные вопросы исчисления и возмещения НДС
        68. Спецрежимы: ЕНВД и УСН. Особенности и сложные вопросы
        69. Налог на прибыль. Расчет, особенности исчисления, спорные моменты
        70. Учетная политика для целей бухучета
        71. Налоговые проверки. Практика применения новых правил
        72. НДС: порядок расчета
      2. Аутсорсинг в вопросах и ответах
      3. Как бухгалтеру выполнить требования Закона «О персональных данных»
      4. Идеальный архив бухгалтерских документов
  • Служебные форумы
    1. Архив
      1. FAQ (Часто задаваемые вопросы)
        1. FAQ: Часто задаваемые вопросы по бухучету и налогам
      2. Игры и тренинги
        1. Тренинг по воспитанию самоуверенности
        2. ВЭД в условиях суровой действительности
    2. Книга жалоб и предложений
      1. Дневники

значит ситуация такая…
при проведении текущей датой все нормально..
но если проводишь документ сделанный раньше выдает ошибку
Значение не является значением объектного типа (установить параметр)
Ошибка при выполнении обработчика — ‘ОбработкаПроведения’
по причине:
{Документ.ЗаказНаряд.МодульОбъекта(182)}: Значение не является значением объектного типа (УстановитьПараметр)
Запрос3.УстановитьПараметр(«Склад», Склад);
код текста обработки проведения выглядит следующим образом:
Процедура ОбработкаПроведения(Отказ, Режим)
////{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
// регистр Работы
Движения.Работы.Записывать = Истина;
Для Каждого ТекСтрокаПереченьРабот Из ПереченьРабот Цикл
Движение = Движения.Работы.Добавить();
Движение.Период = Дата;
Движение.Работа = ТекСтрокаПереченьРабот.Работа;
Движение.Клиент = Клиент;
Движение.ВидРабот = ВидРабот;
Движение.Исполнитель = ТекСтрокаПереченьРабот.Исполнитель;
Движение.Сумма = ТекСтрокаПереченьРабот.Сумма;
//Движение.Количество = ТекСтрокаПереченьРабот.Количество;
КонецЦикла;
//========================================================
Движения.Продажи.Записывать = Истина;
Движения.СтоимостьМатериалов.Записывать = Истина;
Движения.ОстаткиНоменклатуры.Записывать = Истина;
МенеджерВТ = Новый МенеджерВременныхТаблиц;
Запрос = Новый Запрос;
Запрос.МенеджерВременныхТаблиц =МенеджерВТ;
Запрос.Текст =
«ВЫБРАТЬ
| ЗаказНарядПереченьНоменклатуры.Номенклатура,
| СУММА(ЗаказНарядПереченьНоменклатуры.Количество) КАК КоличествоВДокументе,
| СУММА(ЗаказНарядПереченьНоменклатуры.Сумма) КАК СуммаВДокументе
//| МАКСИМУМ(ЗаказНарядПереченьНоменклатуры.Стоимость) КАК Стоимость
|ПОМЕСТИТЬ НоменклатураДокумента
|ИЗ
| Документ.ЗаказНаряд.ПереченьНоменклатуры КАК ЗаказНарядПереченьНоменклатуры
|ГДЕ
| ЗаказНарядПереченьНоменклатуры.Ссылка = &Ссылка
|
|СГРУППИРОВАТЬ ПО
| ЗаказНарядПереченьНоменклатуры.Номенклатура»;
Запрос.УстановитьПараметр(«Ссылка», Ссылка);
Результат = Запрос.Выполнить();
Запрос2 = Новый Запрос;
Запрос2.МенеджерВременныхТаблиц = МенеджерВТ;
Запрос2.Текст = «ВЫБРАТЬ
| НоменклатураДокумента.Номенклатура,
| НоменклатураДокумента.КоличествоВДокументе,
| НоменклатураДокумента.СуммаВДокументе,
| ЕСТЬNULL(СтоимостьМатериаловОстатки.СтоимостьОстаток, 0) КАК Стоимость,
| ЕСТЬNULL(ОстаткиНоменклатурыОстатки.КоличествоОстаток, 0) КАК Количество
|ИЗ
| НоменклатураДокумента КАК НоменклатураДокумента
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.СтоимостьМатериалов.Остатки(
| ,
| Материал В
| (ВЫБРАТЬ
| НоменклатураДокумента.Номенклатура
| ИЗ
| НоменклатураДокумента)) КАК СтоимостьМатериаловОстатки
| ПО НоменклатураДокумента.Номенклатура = СтоимостьМатериаловОстатки.Материал
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиНоменклатуры.Остатки(
| ,
| Номенклатура В
| (ВЫБРАТЬ
| НоменклатураДокумента.Номенклатура
| ИЗ
| НоменклатураДокумента)) КАК ОстаткиНоменклатурыОстатки
| ПО НоменклатураДокумента.Номенклатура = ОстаткиНоменклатурыОстатки.Номенклатура»;
// Установим необходимость блокировки данных в регистрах СтоимостьМатериалов и ОстаткиМатериалов
Движения.СтоимостьМатериалов.БлокироватьДляИзменения = Истина;
Движения.ОстаткиНоменклатуры.БлокироватьДляИзменения = Истина;
Движения.Продажи.БлокироватьДляИзменения = Истина;
// Запишем пустые наборы записей чтобы читать остатки без учета данных в документе
//чтобы при перепроведении записи не задвоились
Движения.СтоимостьМатериалов.Записать();
Движения.ОстаткиНоменклатуры.Записать();
Движения.Продажи.Записать();
Результат = Запрос2.Выполнить();
ВыборкаДетальныеЗаписи = Результат.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Если ВыборкаДетальныеЗаписи.Количество = 0 Тогда
СтоимостьМатериала = 0;
Иначе
СтоимостьМатериала = ВыборкаДетальныеЗаписи.Стоимость / ВыборкаДетальныеЗаписи.Количество;
КонецЕсли;
// регистр ОстаткиНоменклатуры Расход
Движение = Движения.ОстаткиНоменклатуры.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Организация = Организация;
Движение.Склад = Склад;
Движение.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
Движение.Количество = ВыборкаДетальныеЗаписи.КоличествоВДокументе;
// регистр СтоимостьМатериалов Приход
Движение = Движения.СтоимостьМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Материал = ВыборкаДетальныеЗаписи.Номенклатура;
Движение.Стоимость =ВыборкаДетальныеЗаписи.КоличествоВДокументе* СтоимостьМатериала;
Движение = Движения.Продажи.Добавить();
Движение.Период = Дата;
Движение.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
Движение.Клиент = Клиент;
Движение.Выручка = ВыборкаДетальныеЗаписи.СуммаВДокументе;
Движение.Стоимость = ВыборкаДетальныеЗаписи.КоличествоВДокументе*СтоимостьМатериала;
Движение.Количество = ВыборкаДетальныеЗаписи.КоличествоВДокументе;
КонецЦикла;
//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
Движения.Записать();
Если Режим = РежимПроведенияДокумента.Оперативный Тогда
// Проверить отрицательные остатки
Запрос3 = Новый Запрос;
Запрос3.МенеджерВременныхТаблиц = МенеджерВТ;
Запрос3.Текст = «ВЫБРАТЬ
| ОстаткиНоменклатурыОстатки.Номенклатура,
| ОстаткиНоменклатурыОстатки.КоличествоОстаток
|ИЗ
| РегистрНакопления.ОстаткиНоменклатуры.Остатки(
| ,
| Номенклатура В
| (ВЫБРАТЬ
| НоменклатураДокумента.Номенклатура
| ИЗ
| НоменклатураДокумента)
| И Склад = &Склад
| И Организация = &Организация
|) КАК ОстаткиНоменклатурыОстатки
|ГДЕ
| ОстаткиНоменклатурыОстатки.КоличествоОстаток < 0″;
КонецЕсли;
Запрос3.УстановитьПараметр(«Склад», Склад);
Запрос3.УстановитьПараметр(«Организация», Организация);
Результат = Запрос3.Выполнить();
ВыборкаДетальныеЗаписи = Результат.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Сообщение = Новый СообщениеПользователю();
Сообщение.Текст = «В организации на складе не хватает » + Строка(- ВыборкаДетальныеЗаписи.КоличествоОстаток) + » единиц материала «»» + ВыборкаДетальныеЗаписи.Номенклатура + «»»»;
Сообщение.Сообщить();
Отказ = Истина;
КонецЦикла;
КонецПроцедуры

FILED UNDER : Статьи

Submit a Comment

Must be required * marked fields.

:*
:*